Microsoft Transition Your MCTS on SQL Server 2008 to MCSA: SQL Server 2012, Part 2 - 070-458 Exam Practice Test
Question 1
You are developing a SQL Server Integration Services (SSIS) project with multiple packages to copy data to a Windows Azure SQL Database database.
An automated process must validate all related Environment references, parameter data types, package references, and referenced assemblies. The automated process must run on a regular schedule.
You need to establish the automated validation process by using the least amount of administrative effort.
What should you do?
An automated process must validate all related Environment references, parameter data types, package references, and referenced assemblies. The automated process must run on a regular schedule.
You need to establish the automated validation process by using the least amount of administrative effort.
What should you do?
Correct Answer: H
Question 2
DRAG DROP
You administer a Microsoft SQL Server database.
You want to import data from a text file to the database.
You need to ensure that the following requirements are met:
- Data import is performed from a Windows batch file.
- Data is loaded as a unit and is minimally logged.
Which data import command and recovery model should you choose? (To answer, drag the appropriate data import command or recovery model to the appropriate location or locations in the answer area. Answer choices may be used once, more than once, or not at all. Answer targets may be used once or not at all. Additionally, you may need to drag the split bar between panes or scroll to view content.)

You administer a Microsoft SQL Server database.
You want to import data from a text file to the database.
You need to ensure that the following requirements are met:
- Data import is performed from a Windows batch file.
- Data is loaded as a unit and is minimally logged.
Which data import command and recovery model should you choose? (To answer, drag the appropriate data import command or recovery model to the appropriate location or locations in the answer area. Answer choices may be used once, more than once, or not at all. Answer targets may be used once or not at all. Additionally, you may need to drag the split bar between panes or scroll to view content.)

Correct Answer:

Question 3
You are developing a SQL Server Integration Services (SSIS) package to implement an incremental data load strategy.
The package reads data from a source system. Depending on the value in a source column, the package redirects rows to one of five different data flow paths.
You need to add a data flow transformation to support the package redirection.
Which data flow transformation should you use?
The package reads data from a source system. Depending on the value in a source column, the package redirects rows to one of five different data flow paths.
You need to add a data flow transformation to support the package redirection.
Which data flow transformation should you use?
Correct Answer: C
Question 4
Note: This question is part of a series of questions that use the same set of answer choices. An answer choice may be correct for more than one question in the series.
You administer a Microsoft SQL Server 2012 server that hosts a transactional database and a reporting database. The transactional database is updated through a web application and is operational throughout the day. The reporting database is only updated from the transactional database.
The recovery model and backup schedule are configured as shown in the following table:

One of the hard disk drives that stores the reporting database fails at 16:40 hours.
You need to ensure that the reporting database is restored. You also need to ensure that
data loss is minimal.
What should you do?
You administer a Microsoft SQL Server 2012 server that hosts a transactional database and a reporting database. The transactional database is updated through a web application and is operational throughout the day. The reporting database is only updated from the transactional database.
The recovery model and backup schedule are configured as shown in the following table:

One of the hard disk drives that stores the reporting database fails at 16:40 hours.
You need to ensure that the reporting database is restored. You also need to ensure that
data loss is minimal.
What should you do?
Correct Answer: E
Question 5
You administer a Windows 2008 server hosting an instance of Microsoft SQL Server 2012 Standard Edition. The server hosts a database named Orders.
Users report that a query that filters on OrderDate is taking an exceptionally long time. You discover that an index named IX_OrderDate on the CustomerOrder table is heavily fragmented.
You need to improve the performance of the IX_OrderDate index. The index should remain online during the operation.
Which Transact-SQL command should you use?

Users report that a query that filters on OrderDate is taking an exceptionally long time. You discover that an index named IX_OrderDate on the CustomerOrder table is heavily fragmented.
You need to improve the performance of the IX_OrderDate index. The index should remain online during the operation.
Which Transact-SQL command should you use?

Correct Answer: D
Question 6
HOTSPOT
You are developing a SQL Server Integration Services (SSIS) package.
You use a Data Profiling task to examine the data from a source system.
You need to establish: - The minimum and maximum dates for the datetime columns in the source data - The minimum, maximum, and average values for numeric columns in the source data You need to use the appropriate profile type in the Data Profiling task.
Which profile type should you use? (To answer, select the appropriate profile type in the answer area.)

You are developing a SQL Server Integration Services (SSIS) package.
You use a Data Profiling task to examine the data from a source system.
You need to establish: - The minimum and maximum dates for the datetime columns in the source data - The minimum, maximum, and average values for numeric columns in the source data You need to use the appropriate profile type in the Data Profiling task.
Which profile type should you use? (To answer, select the appropriate profile type in the answer area.)

Correct Answer:

Question 7
DRAG DROP
All database traffic to the SQL Server must be encrypted by using secure socket layer (SSL) certificates or the connection must be refused.
Network administrators have deployed server certificates to the Windows store of all Windows servers on the network from a trusted Certificate Authority. This is the only Certificate Authority allowed to distribute certificates on the network.
You enable the Force Encryption flag for the MSSQLServer protocols, but client computers are unable to connect. They receive the following error message:
"A connection was successfully established with the server, but then an error occurred during the pre-login handshake, (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.) (Microsoft SQL Server)"
You notice the following entry in the SQL Server log:
"A self-generated certificate was successfully loaded for encryption."
You need to configure SQL Server to encrypt all client traffic across the network. You also need to ensure that client computers are able to connect to the server by using a trusted certificate.
Which three actions should you perform in sequence? (To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the correct order,)

All database traffic to the SQL Server must be encrypted by using secure socket layer (SSL) certificates or the connection must be refused.
Network administrators have deployed server certificates to the Windows store of all Windows servers on the network from a trusted Certificate Authority. This is the only Certificate Authority allowed to distribute certificates on the network.
You enable the Force Encryption flag for the MSSQLServer protocols, but client computers are unable to connect. They receive the following error message:
"A connection was successfully established with the server, but then an error occurred during the pre-login handshake, (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.) (Microsoft SQL Server)"
You notice the following entry in the SQL Server log:
"A self-generated certificate was successfully loaded for encryption."
You need to configure SQL Server to encrypt all client traffic across the network. You also need to ensure that client computers are able to connect to the server by using a trusted certificate.
Which three actions should you perform in sequence? (To answer, move the appropriate actions from the list of actions to the answer area and arrange them in the correct order,)

Correct Answer:

Question 8
Note: This question is part of a series of questions that use the same set of answer choices. An answer choice may be correct for more than one question in the series.
You administer a SQL Server 2012 server that contains a database named SalesDb. SalesDb contains a schema named Customers that has a table named Regions. A user named userA is a member of a role named Sales.
UserA is granted the Select permission on the Regions table. The Sales role is granted the Select permission on the Customers schema.
You need to ensure that UserA is disallowed to select from any of the tables in the Customers schema.
Which Transact-SQL statement should you use?
You administer a SQL Server 2012 server that contains a database named SalesDb. SalesDb contains a schema named Customers that has a table named Regions. A user named userA is a member of a role named Sales.
UserA is granted the Select permission on the Regions table. The Sales role is granted the Select permission on the Customers schema.
You need to ensure that UserA is disallowed to select from any of the tables in the Customers schema.
Which Transact-SQL statement should you use?
Correct Answer: C
Question 9
You are the lead database administrator (DBA) of a Microsoft SQL Server 2012 environment.
All DBAs are members of the DOMAIN\JrDBAs Active Directory group. You grant DOMAIN\JrDBAs access to the SQL Server.
You need to create a server role named SpecialDBARole that can perform the following functions:
- View all databases.
- View the server state.
- Assign GRANT, DENY, and REVOKE permissions on logins.
You need to add DOMAIN\JrDBAs to the server role. You also need to provide the least level of privileges necessary.
Which SQL statement or statements should you use? Choose all that apply.
All DBAs are members of the DOMAIN\JrDBAs Active Directory group. You grant DOMAIN\JrDBAs access to the SQL Server.
You need to create a server role named SpecialDBARole that can perform the following functions:
- View all databases.
- View the server state.
- Assign GRANT, DENY, and REVOKE permissions on logins.
You need to add DOMAIN\JrDBAs to the server role. You also need to provide the least level of privileges necessary.
Which SQL statement or statements should you use? Choose all that apply.
Correct Answer: A,C,F

